Configuring OpenCDISC Validator for MedDRA

Medical Dictionary for Regulatory Activities (MedDRA) is commonly used for coding Adverse Events. Since MedDRA is only available through a commercial subscription, it’s not included as part of OpenCDISC Validator distribution. However, we have created an easy process by which you can add your company’s licensed copy of MedDRA to OpenCDISC Validator and enable validation checks against the dictionary. Please follow these instructions to configure OpenCDISC Validator for MedDRA:

  1. After successful installation of OpenCDISC Validator, navigate to the /config/data/MedDRA folder. This is where you will store MedDRA files to make them available to the Validator. Each version of MedDRA should be stored in a separate sub-folder (14.0, 14.1, etc.) as is shown below

    OpenCDISC Validator MedDRA folder

  2. The next step is to locate your company’s licensed copies of MedDRA. These are typically maintained by your IT department and are distributed in zip files. Here are the contents of a MedDRA v14.0 zip file

    MedDRA files

  3. Copy the contents of the MedAscii folder to [version] folder under MedDRA. In our example, we would copy the files into /config/data/MedDRA/14.0 folder as is show below

    OpenCDISC Validator MedDRA folder

  4. Repeat steps 2 and 3 for each version of MedDRA you need to support
  5. The configuration is now complete, you are ready to validate data against MedDRA

Selecting MedDRA version for Validation

By default OpenCDISC Validator will use the MedDRA version specified in Define.xml for validation. For example

<CodeList OID="ExternalCodeList.AEBODSYS"
          Name="MedDRA Adverse Events Dictionary"
          DataType="text">
          <ExternalCodeList Dictionary="MedDRA" Version="14.0"/>
</CodeList>

However, if you don’t have Define.xml or it doesn’t specify a MedDRA version, you can now use a new MedDRA field available in the bottom right corner of the Validator screen (see below). The field will become visible once you configure at least one MedDRA version as described in the section above. Also, please note that MedDRA field cannot be used to override a version specified in Define.xml.

OpenCDISC Validator

 

Using a MedDRA version with CLI (Command line Interface)

Using MedDRA with the OpenCDISC CLI is extremley simple.   From the command line, include this parameter with a valid version of MedDRA based on the above examples.  

-config:meddra=14.0

For more information about using the command line, visit CLI usage in the documentation tab